ó
    |chó	  ã                   ó&  • S r S rS rS rS rS rSrSrSrS	r	S
r
SrSrSrSrSrSrSrSrSrSrSrSrSrSrSrSrSrSrSrSrSrS r S!r!S"r"S#r#S$r$S%r%S&r&S'r'S(r(S)r)S*r*S+r+S,r,S-r-S.r.S/r/S0r0S1r1S2r2S3r3S4r4S5r5S6r6S7r7S8r8S9r9S:r:S;r;S<r<S=r=S>r>S?r?S@r@SArASBrBSCrCSDrDSErEgF)Gzä
Descriptive HTTP status codes, for code readability.

See RFC 2616 - https://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html
And RFC 6585 - https://tools.ietf.org/html/rfc6585
And RFC 4918 - https://tools.ietf.org/html/rfc4918
c                 ó,   • SU s=:*  =(       a    S:*  $ s  $ )Néd   éÇ   © ©Úcodes    Ú^/var/www/djangovue.mamus.xyz/django/venv/lib/python3.13/site-packages/rest_framework/status.pyÚis_informationalr	   
   ó   € Ø�$×Ó˜#ÑÐÑÐó    c                 ó,   • SU s=:*  =(       a    S:*  $ s  $ )NéÈ   i+  r   r   s    r   Ú
is_successr      r
   r   c                 ó,   • SU s=:*  =(       a    S:*  $ s  $ )Né,  i�  r   r   s    r   Úis_redirectr      r
   r   c                 ó,   • SU s=:*  =(       a    S:*  $ s  $ )Né�  ió  r   r   s    r   Úis_client_errorr      r
   r   c                 ó,   • SU s=:*  =(       a    S:*  $ s  $ )Néô  iW  r   r   s    r   Úis_server_errorr      r
   r   r   ée   éf   ég   r   éÉ   éÊ   éË   éÌ   éÍ   éÎ   éÏ   éÐ   éâ   r   i-  i.  i/  i0  i1  i2  i3  i4  r   i‘  i’  i“  i”  i•  i–  i—  i˜  i™  iš  i›  iœ  i�  iž  iŸ  i   i¡  i¢  i¥  i¦  i§  i¨  i©  iª  i¬  i­  i¯  iÃ  r   iõ  iö  i÷  iø  iù  iú  iû  iü  iý  iþ  iÿ  N)FÚ__doc__r	   r   r   r   r   ÚHTTP_100_CONTINUEÚHTTP_101_SWITCHING_PROTOCOLSÚHTTP_102_PROCESSINGÚHTTP_103_EARLY_HINTSÚHTTP_200_OKÚHTTP_201_CREATEDÚHTTP_202_ACCEPTEDÚ&HTTP_203_NON_AUTHORITATIVE_INFORMATIONÚHTTP_204_NO_CONTENTÚHTTP_205_RESET_CONTENTÚHTTP_206_PARTIAL_CONTENTÚHTTP_207_MULTI_STATUSÚHTTP_208_ALREADY_REPORTEDÚHTTP_226_IM_USEDÚHTTP_300_MULTIPLE_CHOICESÚHTTP_301_MOVED_PERMANENTLYÚHTTP_302_FOUNDÚHTTP_303_SEE_OTHERÚHTTP_304_NOT_MODIFIEDÚHTTP_305_USE_PROXYÚHTTP_306_RESERVEDÚHTTP_307_TEMPORARY_REDIRECTÚHTTP_308_PERMANENT_REDIRECTÚHTTP_400_BAD_REQUESTÚHTTP_401_UNAUTHORIZEDÚHTTP_402_PAYMENT_REQUIREDÚHTTP_403_FORBIDDENÚHTTP_404_NOT_FOUNDÚHTTP_405_METHOD_NOT_ALLOWEDÚHTTP_406_NOT_ACCEPTABLEÚ&HTTP_407_PROXY_AUTHENTICATION_REQUIREDÚHTTP_408_REQUEST_TIMEOUTÚHTTP_409_CONFLICTÚHTTP_410_GONEÚHTTP_411_LENGTH_REQUIREDÚHTTP_412_PRECONDITION_FAILEDÚ!HTTP_413_REQUEST_ENTITY_TOO_LARGEÚHTTP_414_REQUEST_URI_TOO_LONGÚHTTP_415_UNSUPPORTED_MEDIA_TYPEÚ(HTTP_416_REQUESTED_RANGE_NOT_SATISFIABLEÚHTTP_417_EXPECTATION_FAILEDÚHTTP_418_IM_A_TEAPOTÚHTTP_421_MISDIRECTED_REQUESTÚHTTP_422_UNPROCESSABLE_ENTITYÚHTTP_423_LOCKEDÚHTTP_424_FAILED_DEPENDENCYÚHTTP_425_TOO_EARLYÚHTTP_426_UPGRADE_REQUIREDÚHTTP_428_PRECONDITION_REQUIREDÚHTTP_429_TOO_MANY_REQUESTSÚ(HTTP_431_REQUEST_HEADER_FIELDS_TOO_LARGEÚ&HTTP_451_UNAVAILABLE_FOR_LEGAL_REASONSÚHTTP_500_INTERNAL_SERVER_ERRORÚHTTP_501_NOT_IMPLEMENTEDÚHTTP_502_BAD_GATEWAYÚHTTP_503_SERVICE_UNAVAILABLEÚHTTP_504_GATEWAY_TIMEOUTÚ#HTTP_505_HTTP_VERSION_NOT_SUPPORTEDÚ HTTP_506_VARIANT_ALSO_NEGOTIATESÚHTTP_507_INSUFFICIENT_STORAGEÚHTTP_508_LOOP_DETECTEDÚ!HTTP_509_BANDWIDTH_LIMIT_EXCEEDEDÚHTTP_510_NOT_EXTENDEDÚ(HTTP_511_NETWORK_AUTHENTICATION_REQUIREDr   r   r   Ú<module>re      s¡  ðñòòòòòð Ð Ø"Ð ØÐ ØÐ Ø€ØÐ ØÐ Ø),Ð &ØÐ ØÐ ØÐ ØÐ ØÐ ØÐ ØÐ Ø Ð Ø€ØÐ ØÐ ØÐ ØÐ Ø!Ð Ø!Ð ØÐ ØÐ ØÐ ØÐ ØÐ Ø!Ð ØÐ Ø),Ð &ØÐ ØÐ Ø€ØÐ Ø"Ð Ø$'Ð !Ø #Ð Ø"%Ð Ø+.Ð (Ø!Ð ØÐ Ø"Ð Ø #Ð Ø€Ø Ð ØÐ ØÐ Ø!$Ð Ø Ð Ø+.Ð (Ø),Ð &Ø!$Ð ØÐ ØÐ Ø"Ð ØÐ Ø&)Ð #Ø#&Ð  Ø #Ð ØÐ Ø$'Ð !ØÐ Ø+.Ñ (r   